Jump to content

Trying to burn anything hangs CDBurnerXP

Recommended Posts

I was having problems starting CDBurnerXP (see this thread:

The update to allowed it to start successfully again but I can no longer burn ISOs anything. What happens is I start CDBurnerXP and from the initial dialog I choose "Burn ISO image". The next dialog appears and I choose the ISO file and click "Burn disc" at which point it stops responding. The disc doesn't get burned and I can eject the disc (using the physical eject button) from the burner without issue but CDBurnerXP is completely unresponsive. It can't be closed in any way. Trying to close it does nothing, and even trying to end the task in Task Manager has zero effect. It literally makes it impossible to shut down/restart windows. I have to do a hard power off.

Thinking maybe this is an ISO burner issue only I just attempted to burn a data compilation. Picked about 3GB of random files and tried to burn them. When I click the "Burn CD" button CDBurnerXP's title bar changes to include "Not Responding" at the end and the cursor changes to a waiting cursor but nothing happens. The disc is no actually being burned and CDBurnerXP is showing in Task manager as not responding. I can eject the disc using the physical button but CDBurnerXP is hung. Just like with the ISO, I can't close CDBurnerXP using Task Manager and have to physically power down my PC to get rid of it.

Some more information:

I was trying to burn the Windows 10 Home Image to disc when the initial error occurred.

Data was just a random collection of about 20 Zip files.

Happens whether there is a disc in the tray or not.

They're the same TDK blank DVD-R discs I've used in the past. Have burned a half dozen from the spindle before with no issues, including ISOs (including the same Windows 10 ISO).

Upgraded to and the issue remains.

Tried using a different ISO burning program (FreeISOBurner) as an experiment and it worked just fine with the same ISO on the same media.

Running Windows 8.1 64Bit patched up to date.

If there is any more information I can provide please let me know.

Link to post
Share on other sites

Thanks I'll give that a whirl to see if it helps.

I am curious though, CDBXP was working fine a couple versions ago, even burning the same image on the same media. I haven't changed hardware in my PC and there is no new software either. The only things that have changed have been Windows Updates and CDBXP itself. And I guess the antivirus software updates it's signatures all the time.

Any thoughts on what might have changed?

Link to post
Share on other sites

CDBurnerXP gets an updated version of the burning library on a regular basis, so it could always happen that some change in the library causes a different behaviour on your system. If you know what version of CDBXP exactly worked previously, it's possible to check if there was a burning library update.

Link to post
Share on other sites
  • 1 month later...

Sorry for the late reply to this. I haven't needed to burn anything since the last post, til today.

Fired up CDBurnerXP and nothing happened, no visible CDBurnerXP window. Checked task manager and there is a process there. Just like the old version it couldn't be ended. I had to do a hard reboot because the PC would not restart using the proper restart procedure.

After rebooting I tried the newest version listed on the site and just like my first post in this thread it would start successfully but then would hang if I actually tried to burn anything. Again, I could not kill the process in task manger and was unable to restart windows properly. Had to do a hard reboot again.

Just need to add after another reboot now doesn't show when I try to launch it either. I can find it in Task Manager, and again, can't kill it and have to hard reboot Windows :( I'm thinking the one time the CDBurnerXP window actually appeared was straight after install.

Just to confirm that the burner and media is actually working fine I used FreeISOBurner to burn the ISO and it worked just fine.

I should note, I have the SPTD drivers installed as suggested so they obviously didn't help.

Just regarding your comments about the burning library - well that shouldn't have mattered. As I stated, the old version (don't remember what number sorry) worked fine initially then stopped working with no warning and no CBurnerXP upgrades. In other words the library hadn't changed so the library couldn't have broken it.

I will try to find a really old version and give that a whirl but I'm inclined to think it's something 3rd party that's causing the problem.

Is there anything else I can provide information wise that might help diagnosing the problem?

Link to post
Share on other sites

I had a look at that link and it doesn't really help. I have no virtual drives installed, only have standard USB devices - Logitech USB Mouse & Keyboard. Logitech Mouse uses either wireless or corded so it has a USB dongle too. It is however the same setup I've been using for ages and it worked fine before. The problem occurs regardless of whether a disc is in the drive or not.

On an interesting note, I updated (update keeping all my apps and files not a clean install) to Win10 Pro 64bit after my last post (planning to roll back to Win8.1 64bit in the next week or so) and CDBurnerXP works again. I'm more convinced that ever that there is something in Windows that is to blame. I'll update with a fresh post once I roll back to Win8.1 and let you know if CDBurnerXP is working or not in it again.

Link to post
Share on other sites
  • 5 months later...

Sorry again for the super long delay between replies. Real life can be a pain :( and the rarity of burning a CD/DVD tends to make me forget about the problem.

Rolled back to Windows 8.1 and CDBurnerXP doesn't work again. Surely it's gotta be something in Windows that's broken it.

Not sure whether it's worth your while trying to fix it, but there are still a lot of people on Win 7 and 8. If there is any information I can provide that's useful let me know.

Link to post
Share on other sites

Just wanted to say it's working again! I realised after I rolled back to Win8.1 that there was a newer version of CDBurnerXP available so I installed that and it works. Not sure what changed but it's nice to have it working again. Fingers crossed it stays that way.

Link to post
Share on other sites
  • 5 months later...

found this thread from Google search. First time user and I'm using version (the 32-bit version) on windows 10 x64. Tried copying audio CD and CDBurnerXP would hang during the burn phase. Progress bar stuck at 50%, pressing cancel didn't seem to do anything, and pressing the physical eject button on the CD drive. CD drive stuck in slow blinking mode. Doing a restart did not bring back the drive to working. Needed to do a power cycle (shut down and then boot) to fix it. This hang was reproduced one more time, so I've wasted two CDs during this process. Fortunately they're cheap.

Installing SPTD drivers seems to have fixed my problems, in case other people still run into a similar problem.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.