Jump to content

Cant copy DVD disc to ISO image on extFAT USB 3.1 flash drive

Recommended Posts

12 hours ago, floele said:

Did you try changing the file system to UDF?

UDF on USB stick?

I need to make image of DVD, and save it directly to .iso file on USB stick. The extFAT file size limit is 16 EB  (DVD size only 4.7 GB), but I cant make image. I try to select both: .iso and .mds, but  error is same "Wrong file size"


Link to post
Share on other sites
  • 4 weeks later...

Hi, I encountered the same error "0x80040294, dec 660, STARBURN_ERR_FILE_WRONG_SIZE" while attempt to write an 1.02 UDF ISO File to an extFAT external USB3.0(?) Storage (MyBook 8TB).  also tried UDF 2.60.

The ISO is 4834,25MB (2819 folders and 66903 files). I wanted to decrease space usage on that 8K blocksize external hdd disk, by putting the small files into a big ISO.

The ISO needs ~4.18GB on disk and the entire content as file structure needs 67,6GB ...


2020-09-30 01_43_59-Eigenschaften von HTTPweazles_mirror_error_oldlinux.txt, ....png

CDburnerXP on Windows 10 2004


I only found this thread and this table https://cdburnerxp.se/help/references/errorcodes
I'm not sure though, what's the meaning. Doesn't the target file system exFAT support the size? The Disk is quite filled up, 900GB free.

I'm currently writing it to my NTFS formatted SSD @ C: This seems to work.


It worked and I can even copy it without any issues to the exFAT drive. So this is a workaround. Save to NTFS and then copy it over to exFAT.


I'm using cygwin.

$ pv "C:\Users\floogy\Downloads\ollinuxprinceton.iso" > "L:\Data\outsourced data\OS\Linux\Historic\mirror.math.Princeton.edu"/oldlinux@mirror.math.Princeton.edu_[20200929].iso
4,53GiB 0:00:46 [98,9MiB/s] [===========================================================================================================>] 100%

$ mount | grep L
L: on /cygdrive/l type exfat (binary,posix=0,user,noumount,auto)

$ df -h /cygdrive/l
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
L:              7,3T    6,5T  834G   89% /cygdrive/l


Maybe the Author of this fine piece of software may got an idea what's going on here.

Thank you in advance.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.