Jump to content
Sign in to follow this  
vitalis

Ukrainian translation (

Recommended Posts

How to test translation with CDBXPP

At first, download and unpack the attached file (release.zip). Start compile_lng.exe and convert your resx file (if you are a tester, get it at http://www.cdburnerxp.se/translation.php ) to a DLL file. Place it into the sub directory of CDBurnerXP program directory which comes up to the language code of your language or create a new one if it doesn't exist yet. (Re)place the existing file in there and make sure CDBXPP really uses that language (change language in settings). Then start CDBXPP and see the result

I can't compile my *.resx file :-/

cdbxpp.PNG

Share this post


Link to post
Share on other sites

My steps...

1. I translate Strings.resx file (not fully);

2. Convert it in UTF-8;

3. Open it in Firefox and Firefox says:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

4. Put the Strings.resx in folder with unpacked archive for compalation *.resx to *.dll;

5. Start the compile_lng.exe file and push "Compile" button;

6. But file doesn't convert to cdbxpp.resources.dll :cry:

Share this post


Link to post
Share on other sites

Maybe it helps if you download the program again, the first version had some bugs hich might cause a failure.

About what program do you say? About compilator? I'll try.

Share this post


Link to post
Share on other sites

My steps...

1. I translate Strings.resx file (not fully);

2. Convert it in UTF-8;

You made a mistake. You did not use UTF8 encoding. Without that it won't work.

Use Notepad2, as Flo recommended in the topic. Use File >> Encoding >> UTF8 to convert it to UTF8, then save it.. additionally, it's recommended to make UTF encoding default and not converting every time (by selecting File >> Endoding >> Default >> UTF8 ..)

Share this post


Link to post
Share on other sites

Oh, I forgot to say that you have to change encoding BEFORE translation.

Yep :!: That's the problem.

But I already repair this problem! :P

I translate in Notepad2 and then I encode file AFTER translation in Windows Notepad (Save as -> Encoding UTF-8 ). All is OK :)

But :roll:

Now my CDDBXPP (ver. 3.5.101.4) don't want to open with Ukrainian interface. I set language to Ukrainian, restart the program and they start in English. In options shown Ukrainian language as language of interface.

Maybe that's because Ukrainian lang. was not in release of that version?

And one more. In option Select Language Ukrainian (in native) shown as óêðà¿íñüêà but in that case in program must be written as Óêðà¿íñüêà (first letter must be in upper case).

When be released public version of program?

Share this post


Link to post
Share on other sites

I think the display in Settings dialog is done by .NET and it is OK like that ;)

I will have a look at your file and let you know what is wrong.

The public version should be released in March.

Share this post


Link to post
Share on other sites

But :roll:

Now my CDDBXPP (ver. 3.5.101.4) don't want to open with Ukrainian interface. I set language to Ukrainian, restart the program and they start in English. In options shown Ukrainian language as language of interface.

Maybe that's because Ukrainian lang. was not in release of that version?

I already discover the problem. I compile my translation as ru-RU and then replase they with Russian translation in program folder. All works.

Where I my to send my *.dll file after full translation and compilation.

Share this post


Link to post
Share on other sites

You set the language wrong in the compiler (atleast in the screenshot you send)

in the screenshot it says uk-UA

must be ua-UA otherwise it wont work i think. :)

hope that helps

greets,

AJ

Share this post


Link to post
Share on other sites

You set the language wrong in the compiler (atleast in the screenshot you send)

in the screenshot it says uk-UA

must be ua-UA otherwise it wont work i think. :)

hope that helps

greets,

AJ

Share this post


Link to post
Share on other sites

You set the language wrong in the compiler (atleast in the screenshot you send)

in the screenshot it says uk-UA

must be ua-UA otherwise it wont work i think. :)

No, there all is OK. Not in all language codes (xx-XX) first latters (xx) matchs with second letters (XX).

See here (at bottom of post): viewtopic.php?t=1479

OK, so I assume the problem is fixed?

Yes, I hope :roll:

Share this post


Link to post
Share on other sites

All text in tabs of CDBurnerXP Pro Options is untranslable. That's mean that strings from this window is no presented in language file (*.resx). It will be fixed?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.