Jump to content

re-enable autorun on Windows XP?


Recommended Posts

Guest taosu

Okay, now that I checked "yes" to the "disable autorun" popup on CDBurner XP, how do I re-enable autorun? And I don't want to hear "Go to my computer, right click the cd drive, click properties, click on the autoplay tab, blah blah blah..." because on Windows XP, that autoplay tab only allows you to select the following content types: music files, pictures, video files, mixed content, music CD, and DVD. and the only autoplay options it gives you are: play with Windows Media Player, browse with Windows explorer, or Take no action.

I don't care about multimedia files, I just want to know how to get the autorun working on cd-roms with program software on it, because I have this 18 Languages software cd-rom set that only plays from the cd-rom with autoplay for anti-piracy reasons.

Sigh, I miss the good ol' days of Windows 98 when autoplay was autoplay. Sure the darn OS crashed five times a day, but at least I had CONTROLL.

much obliged :cry:

Link to post
Share on other sites
Guest sh1leshk4

To enable/disable Autorun in Windows XP via registry :

Open up regedit, and go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

Look for the key 'AutoRun', and toggle between 1 for 'Enable' and 0 for 'Disable'.

Link to post
Share on other sites
Guest sh1leshk4

Oh, I forgot to mention this.

Be sure to restart your Windows after applying the change in registry for the change to have any effect.

Link to post
Share on other sites
Guest taosu

Go to my Computer->rightclick on your drive->properties->AutoPlay

very funny Flo. I KNEW someone was going to say that.

Link to post
Share on other sites
Guest

sh1leshk4 wrote:

Open up regedit, and go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

Look for the key 'AutoRun', and toggle between 1 for 'Enable' and 0 for 'Disable'.

Thank you so much sh1leshk4!! That registry edit thing worked perfectly! Not only did I set the autorun key back to 1, I also found a "permanently disable autorun" key that was preventing even the "right-click the drive" method from working. I deleted that key and now I can run my software from my drive and everything. It's nice that there is at least ONE person out there with useful advice.

^.~

Link to post
Share on other sites
Guest

No problem. =)

But I guess I forgot to edit out the backslashes...

I set the locale to Japanese, and that what happens to every single backslashes in the system; it's converted to a Yen sign. o.O

Link to post
Share on other sites
  • 1 year later...
Guest myself

thanksto sh1leshk4. it worked perfectly

the only think that I wanted to add is that you can also uninstall and reinstall the CDrom so you wan't have to reboot Windows

Link to post
Share on other sites
  • 4 months later...
Guest 2ILUAXZ

Hello friends,

I am new to this forum. I am into the same problem with VMware for Win2000 as a guest system low resolution (600X800). As suggested in the thread i have checked the Autorun from registry and it is alredy set to 1. But when i try to install the VMware tools, i don't see any thing happen. I am trying to run Win 2k guest from Win XP. My VMware version is 5.5 and i am booting the guest system from ghost image. Please advice on how to increase the resolution.

Krish

Link to post
Share on other sites
  • 4 months later...
Guest opalsboy

I have learned a really really simple way to fix the auto run in winxp. Use TweakUI. Google for "Tweak UI Program" Read up on it if you need to. After you decide it is a legitimate Microsoft program,follow these steps.

1. Download and install TweakUI.

2. Run the program. Screen will open with many options for things.

3. Click on "My Computer", "Auto Play","Drives", Choose the Drives you want to turn on Auto Play for. "Apply", "OK"

4. Close Tweak and you should be off and running.

Link to post
Share on other sites
  • 1 year later...
Guest ApplePie2luv

Hey,

So I've tried all these things and autoplay still won't turn on. When I right click the drive, properties, autoplay it says "prompt me each time". My registry is set to 1 even after restarting the computer. I've run WGAPluginInstall that Microsoft said would work and the TweakIUPowertoySetup suggested below, they both just clicked next and next thing it said finish (no options to select drives or anything). I'm completely out of ideas, do I need to reinstall something from my XP CD?

Thanks

Link to post
Share on other sites
  • 10 months later...
  • 4 weeks later...
Guest Acemoser

THANK YOU YOU ARE A GOD SEND!! I was able to fix a dozen other problems as well with the registry "regedit" method!!! THANK YOU!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.