Jump to content
Sign in to follow this  
sinnabor

"Disable ISO version number extension" creates corrupt ISO/C

Recommended Posts

I'm trying to create a bootable XP install disc (from my old completely legal XP install disc, plus SP2 slipstreamed) following the instructions on http://www.cdburnerxp.se/help/Data/bootdisc. When I check "Disable ISO version number extension" as suggested, the resulting ISO image or CD is useless. ISObuster can't even find/open the subdirectories. The burned CD's are all coasters - some will boot, but the installer won't even make it to the license agreement.

If I turn that checkbox off, the ISO looks fine. The burned CD looks fine... though it doesn't boot. Hmpf.

I don't know enough to tell for certain if this is a bug with CDBurnerXP or with the instructions. Shouldn't Windows be able to read any valid CD-ROM, though? Why does that checkbox make the ISO/CD useless? I can only assume that it's corrupt.

Share this post


Link to post
Share on other sites

Oh, and if it matters, I've tried this on both Windows XP SP2 and Windows MCE 2005 with the same result. I did fresh installs of cdburnerxp and .net framework to rule out random failures.

Share this post


Link to post
Share on other sites

Hmmm. I think that your problem is the load segment value. A google search with the terms "load segment for creating xp bootable cd" shows

07C0 (which actually is the one showed on the help file, if you skip the leading zero). Having created such a working disc myself, in a galaxy far far away, using this value as far as I can recall, this should work. Though I don't remember that much the same search also shows Number of loaded sectors = 4

The "Disable ISO version number extension" should be checked, while "enforce level 1" is optional, used for compatibility reasons.

I will try to create a XP SP3 disc in a few days.

If you can't wait and you aren't reluctant in creating another useless CD, try that.

Some links that show the above:

http://www.winsupersite.com/showcase/windowsxp_sp2_slipstream.asp

http://old.bink.nu/xpbootcd/

http://www.onecomputerguy.com/install/winxp_bootable.htm

Resuming:

Load Segment = 7C0 (or 07C0 its the same)

Loaded Sectors = 4

Disable ISO version number extension CHECKED

Enforce level 1 OPTIONAL (Try CHECKED first)

As for labels they are useful, I don't know why, I think that they are used by the installer to recognize the disc, you have the correct ones:

http://www.tacktech.com/display.cfm?ttid=342

http://www.tacktech.com/display.cfm?ttid=422

Tell us if these work... :)

Share this post


Link to post
Share on other sites

It seems the problem lies with the enforce level 1 restrictions. If it is checked, the resulting ISO file is corrupted.

The bug can be reproduced by making a slipstreamed XP SP3 ISO. Put the XP SP3 files into the image, in the boot options check both enforce level 1 restrictions and remove the version extension. Save the image as an ISO. It should be corrupted when mounted with daemon tools or burned to a disc.

This is a pretty severe bug, I just wasted four or five hours burning corrupted images. Good thing those were rewritable discs!

Share this post


Link to post
Share on other sites

I had this problem today, too.

I only have a very bad workaround.

Create a new project, than instantly set boot informations (image, no emulation, 7C0, no versioning) and then insert the files (eventually also change filesystem to ISO/Joilet in Media/Filesystem). After that every bootable CD and/or Image had worked.

You have to do all manually. When a project is loaded the boot informations are not set and after that setting the boot-informations will result in either not readable but bootable , or a readable but not bootable CD (seems not to be saved at least in 4.0.24, but the new one had many locks up, especially when loading projects with 5000+ files).

Edit: Same problem with 4.1.2. It also seems, that a project, that is loaded and burned, is very instable as it locked up 2 times with C++ Error Virtual call R4029(?) I think. One time burning a real CD (ok, R/W) and the second time creating an ISO with the same data (as CD-drive locked up). At least the burning ran till end in background when the "OK" button from the error-message was not pushed.

Yours,

Markus

Share this post


Link to post
Share on other sites

I confirm it, if you change the iso option from the "Boot options..." after you insert your files into the compilation, you will have a bad CD, if you insert your file after changing those option

- both check

- Load Segment = 0000 (as on the original cd work ok at 07c0 too)

- Loaded Sectors = 4

- Disable ISO version number extension CHECKED

- Enforce level 1 CHECKED

- NO EMULATION

- ISO LEVEL 2 (31)

If you insert your file before, just remove them from the compilation and readd them!

St├ęphane

Share this post


Link to post
Share on other sites

I do not have any time to verify such problems currently. And even if I had, I'd wonder whether NMS would actually care about my reports. Until they release 2.0, there won't happen anything.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.