Jump to content
Sign in to follow this  
ibobalo

UDF - invalid filesystem created

Recommended Posts

every time i'm trying to burn disc or create ISO with UDF filesystem (ISO9660/UDF/Joliet or ISO9660/UDF or UDF) and 1 big file (>~4470M) a got same error:

in windows explorer it looks ok (may be just ignore error) and file content reads fine.

but in DOS session it reports error: The file or directory is corrupted and unreadable. Cannot read folder contents.

dir command reports:

======

F:\>dir

Volume in drive F is XXXXXX

Volume Serial Number is XXXX-XXXX

Directory of F:\

10.12.2007 16:14 4 691 392 626 XXXXXXXXXXXXXX.XXX

File Not Found

=======

in nero i never had such UDF errors.

CDBurnXP v.4.0.022.370

Windows XP SP2 with all updates.

Share this post


Link to post
Share on other sites

something very like this happened to me, too, using cdburner xp 4.0.022.370 with hacked runtime (no way will I install 200 MB of .net 2.0) under w2k sp4. never had the problem using 3.0.116 (I sure wish I hadn't wasted several hours and CDs by upgrading). the CD burn process seemed to go fine, but then when it came to reading the disk, that was another question. Depending on what I put on the disk, sometimes directories were simply invisible, and other times there were the messages about them being corrupt. The latest disk, several tries, had about 630 MB of files in a number of directories, and only one directory and no files were visible afterwards. Even cdburner xp couldn't import the session. But ISOBuster didn't seem to have a problem, showed everything where I would have expected it, though I didn't actually read the data. I'm going back to 3.0.116. I thought this wasn't supposed to be a beta, how come the problems? I contributed, based on past use, without considering that the new version could be unusable.

Share this post


Link to post
Share on other sites

I have same errror while recording data DVD. My project contains ~30 files, and the result is - one file is missing (I dont see them in Explorer, but FAR session give the same error message - "The file or directory is corrupted and unreadable. Cannot read folder contents."), all other files reads OK.

I try two times - the result was identicall.

I have latest CDBurner version installed, .Net v2, WinXP with SP1

Share this post


Link to post
Share on other sites

Same thing here.

I've noticed it happens when I'm very close to having a full disc (i.e: 448x MB). This might be related.

I was using BurnToTheBrim to pack my media as much as possible.

The exact size of my compilation was 4486,56Mb, which is slightly over the top (about a meg and a half's whorth).

In any case ISOBuster seems to see the filenames properly but not in the UDF format.

The files also can be saved OK with ISOBuster but I didn't do a byte for byte comparison. The last file in the compilation might be corrupt.

Or maybe what is happening is that the extra 1.5 meg is walking all over the UDF descriptions (hence the missing files). I don't know squat about the DVD file system so this is a wild guess.

I'm going to try to see if selecting Disc --> File system --> ISO9660/Joliet will help with the exact same compilation. I'll post the results here. Mind you, not having UDF means you can't have a file larger than 2gigs, which might be a problem for some people. Also, UDF is the only format that can be read on a DVD so if my trick works it might not be a viable solution for those who do a lot of movie DVDs.

I've been looking for a long time for a simple, practical remplacement for Nero the 800lbs gorilla. Until this issue is resolved I'm still searching (sadly).

Share this post


Link to post
Share on other sites

Yup that worked.

So I guess it's sorta official; UDF filesystem is buggy for now. I don't know if it's caused by filesize or by some other factor.

I'm going to test some more and I'll keep you guys posted.

Share this post


Link to post
Share on other sites

Well so far so good if I'm not doing a UDF DVD.

One more thing though, I'm not sure if this is related but there's another interesting bug in CDBurnerXP; it's possible to end a filename with a space, which I'm sure is a no-no. I'm wondering if this isn't related to this problem?

Share this post


Link to post
Share on other sites

Well FYI the problem has now shifted a bit.

While the DVD verified OK and all the files appear, a whole bunch of files are simply unreadable and I have to use IsoBuster to get them back.

I'm using 4.0.022.370

My burner: HL-DT-ST DVD-RAM GSA-H55N (1.03)

Windows XP 32bit SP2 French

Burning DAO, ISO9660/Joliet, 12x or 8x on TDK DVD-R media

Until these issues are resolved, I have to consider CDBurnerXP unreliable - I don't want to discover a year from now that my DVDs didn't burn properly (even though the program verified the files and said they were OK!!!!). In any case it is clear there's a problem writing the directory information. For some reason the ISO part is OK but the Joliet is fscked up in some way - the OS chokes on it. I guess IsoBuster just ignores the erroneous description and reads the file anyways.

Last but not least, the program crashed on me a few times when there was a lot of files and I was too quick on the mouse buttons. Might be a few leaks here and there too. I'll check back on CDBurnerXP in a few months ...

Share this post


Link to post
Share on other sites

This bug seems to still exist in version 4.2.2.1012.

I've been writing 6 files to a DVD-R, but only 5 are reported by the UDF. ISO and Joliet file systems do show all 6 files.

The disc is not quite full since the files are only using a total of about 4194.48 MB. After extracting the missing file with IsoBuster 2.5 it's MD5 hash is correct, so it's complete and intact.

Additional info:

6 files (4,398,227,456 bytes in total)

4,398,848,000 bytes used as reported by Windows XP SP3

4,399,759,360 bytes (2,148,320 blocks) used as reported by IsoBuster 2.5

Burner used: HL-DT-ST DVDRAM_GSA-T50N


Disc type as reported by IsoBuster 2.5: DVD

Disc state as reported by IsoBuster 2.5: finalized

Erasable as reported by IsoBuster 2.5: no

Tracks as reported by IsoBuster 2.5: 1

Sessions as reported by IsoBuster 2.5: 1 (closed)

Layers as reported by IsoBuster 2.5: 1


UDF info as reported by IsoBuster:

VD Address: 32

VD Size (Blocks): 1

VD Size (Bytes): 2,048

Type: UDF

File System: UDF 1.02

Platform: Windows 95

Root Address: 2147862

Root E(FE): 2147861

Root Offset (Bytes): 0

Application: NMS DVDProLib


FS Structures:

Partition (LBA): 257

LVD (LBA): 35

PVD (LBA): 32

FSD (LBA): 2147860

VAT (LBA): 0

Sparing (LBA): 0

Share this post


Link to post
Share on other sites
Guest ExposuresLTD

I get the same problem in the newest version 4.2.4.1430. I burn files to a DVD and they simply don't show up. The disc reads as full and with the correct amount of data on it, but Windows, CD Burner XP, and other graphics programs won't read the files. The folders don't even show up in Windows Explorer! I guess I need to find a reliable burning utility.

Share this post


Link to post
Share on other sites

I'm reactivating this thread, as it fit my needs best.

I've got problems with UDF-formated discs as well. I've tried burning UDF discs several times and every time CDBXP tells me the disc has been burned successful; I even ran verification test after burning but the created discs are unreadable. I tested reading the discs under Win XP x86, Vista x64 and Win 7 x64 but they all state that the discs are corrupt.

FYI, my PC Config:

- Windows 7 Professional x64, alway latest CDBX version.

- Burners: LG GSA-H62N (DVD-burner) and LG GGW-H20L (BluRay-/HDDVD-burner) [tested burning UDF with both drives!]

- Tested burning with DVD+Rs (single and double layer)

My CDBX settings for burning:

1.) Pre set File system: UDF (tested Joliet/ISO/UDF with same results.)

2.) Files are around ~4500GB or ~8000GB MKV-Videos (depending on disk)

3.) Burning files as "Data-Compilation"

4.) When CDBX asks me, whether to finalize disc or not, I choose "advanced settings" (not sure if translation is correct, as I use the german translation).

5.) I set session type to Disc-at-once (also tested it with the other option), activate "finalize disk" and in addition "check disk after burning".

6.) After the process is finished, I try to read the CD, but the disk is shown to be defect, though the data seems to be on the disk and the medium is finalized.

Let me state that burning ISO-formated discs works flawlessly, but UDFs won't work at all. :( Anybody an idea what's the problem here?

Share this post


Link to post
Share on other sites
Guest Amiral Benson

I have the same bug as you guys, when I burn files on a Blu-ray (BD-R 25 Go) with UDF, Disc-at-Once, I always check the option to verify the disc after burning, and CDBurnerXP tells me that a large number of files are missing because of an error with the files system.

When I check myself the disc in the Windows Explorer, some folders are missing, but the disc properties reports that the total size match the total size of the files which I wanted to burn.

All the three Blu-ray for three different compilations that I burn today ends up with this same error.

But every time in its report CDBurnerXP tells me also that all the files were successfully burnt.

I use the last version of CDBurnerXP: 4.2.7.1893

OS: Win 7 Pro 64 bit

Blu-ray Burner: Plextor PX-B920SA (FW 1.03)

Disc: MediaRange BD-R 25 Go

What can I do ?

Share this post


Link to post
Share on other sites

Grrr... I noticed that I was flawlessly able to read UDF disc burnt by CDBXP on Linux. I guess the problem is related to different versions of the UDF filesystem itself, as not all OSes support the same UDF version and even if they do, they don't support all partion types (physical, virtual, spare):

-> http://en.wikipedia.org/wiki/Universal_ ... OS_support

But I wonder, why I'm not able to read CDBXP-UDFs on Vista/Win 7 as they should be able to read all UDF versions. And in addition the CDBXP manual states, that CDBXP will use UDF 1.02 for all CDs. So there shouldn't even be a problem with Win XP?!

And to make that clear: If I burn an UDF disc with Nero 8, the disc I completely readable on XP, Vista and Win 7! Nero regulary uses UDF 1.02 and physical partition types. So what's CDBXP using, that it's so incompatible with Windows?

Share this post


Link to post
Share on other sites
Guest Amiral Benson

Thanks R(i)SK for your tests.

The manual of CDBurnerXP states also that While DVD-Video media use UDF version 1.02, Blu-ray media use UDF 2.50 or UDF 2.60., so I guess that when I'm burning a data Blu-ray in UDF, it is with UDF 2.50.

Share this post


Link to post
Share on other sites
Guest Amiral Benson

If that helps, when I was using a previously version of CDBurnerXP on Vista 32 I hadn't these UDF bugs with Blu-ray.

Share this post


Link to post
Share on other sites

Ok, as things still bother me, I have made some further testing on burning UDF disks. And just to emphasize - I'm talking about writing UDF to a dvd disk!

Meanwhile I've downloaded Phillips' "UDF verification software" and tested my UDF discs burnt by CDBXP and it throws out 1 warning and 3 error on the discs.

I've uploaded the log here:

-> http://pastebin.com/fc7d16fa

Maybe one developer could take a look at it?

Share this post


Link to post
Share on other sites

It seems my post is related to this thread.

I'm using the latest version 4.3.2.2140

I'm using the following to create a multi-session CD

cdbxpcmd --burn-data -device:0 -folder[\\XXX]:c:\\YYY -name:SN -import -verify -eject

and it can add additional sessions fine.

However when I try to read the CD with the Windows interface of CDBurnerXP I get the following error:

"Invalid UDF tag".

I can see the contents of the CD fine in Windows Explorer in XP, Windows 7 - 32 bits, Windows 2000.

Shoshana

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.