Jump to content
Sign in to follow this  
jeremy78

Boot CD can't see folder structure or any files?

Recommended Posts

I needed to create a bootable ISO image, and I didn't particularly want to waste an actual CD (our servers will boot off of the image), so I downloaded CDBurnerXP today. I happened to have all the files I needed on a floppy disk, and I created a bootable image from that disk. Booting off of this worked fine.

But, I'm trying to create a new compilation with more data than just what's on the floppy. The only thing that shows up are the files & directories that were on the floppy; the rest of my compilation is not there. I tried several of the options when creating a floppy image, and it's always the same. Am I doing something wrong?

Share this post


Link to post
Share on other sites

I am having a similar problem with a compilation. I can create a boot CD by selecting my floppy boot image in the Boot Options window and then dragging the boot image files (minimum Win98 system files) from a work folder to the compilation. I can then burn the disk and boot to it. However, when creating the compilation if I add any folders (i.e. Ghost, DOS) to the compilation and burn it, the CD is not bootable. I'm not sure what it going on here.

Share this post


Link to post
Share on other sites

Can someone respond to my post. I have searched this forum for my particular problem and have not found it. I think my problem may be procedural (i.e. user error) but i would at least like to know.

My steps to create a boot disc are as follows:

- Launch CDBurnerXP app

- Select Data disc and click OK

- Click Disc menu and select Boot Options

- Check Make disc bootable

- Select the path to the boot image (Win98 floppy image)

- Select Emulation type: Floppy 1.44 MB (95/98/ME boot images)

- Use defaults for remaining settings

- Click OK to close Boot Options

- Click Disc menu and select File System

- Make sure the file system is set to ISO 9660/Juliet

- In User Data browse to the folder where the files have been extracted from the boot image

Note: these are the minimum Win98SE boot image files (i.e. command.com, io.sys, msdos.sys, himem.sys, config.sys, autoexec.bat, mscdex.exe, oakcdrom.sys)

- Drag the boot image files to the compilation

- Insert a re-writeable DVD disc into the DVDROM

- Click Erase and verify the DVD disc is erased

- Click Burn

- Test that the disc is bootable

Result - The DVD is bootable (the disc is read and the system boots to A:). My config.sys and autoexec.bat files configure the CD/DVD ROM to be drive F:. Looking at this drive I see it contains the same files as A:

If I repeat the exact same steps EXCEPT that I also drag folders containing apps (Ghost for example) the resulting burned CD is not bootable.

What am I doing wrong?

It is my understanding that MSCDEX redirector makes the CD/DVD ROM appear (to DOS or Windows) the same as a network drive. So it doesn't matter how many files/folders are on the drive.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.