Jump to content
hassanmullah

/LANG=language does not function

Recommended Posts

Hello,

under the URL http://unattended.sourceforge.net/InnoS ... Codes.html there is following standing:

/LANG=language


    Specifies the language to use. language specifies the internal name of the language as specified in a [Languages] section entry.


    When a valid /LANG parameter is used, the Select Language dialog will be suppressed.

So i install CDBurnerXP 4.* with the default language english and the additionaly language german. I don't want have to see the first window where the user can select the language.

So my parameter was /LANG=german. But when the user first time start CDBurnerXP, he will get asked for the language. :o

Is that a bug, or what ??

kind regard

Holger :firefox:

Share this post


Link to post
Share on other sites
Guest ThomasX

But it doesn't really answer the question does it?

I'm distributing this in a large environment and want to standardize to what language the users get and the only way to do that (with the older versions) was to delete the folders where the languages were except the one you wanted. You still did get that Pop-up, but at least there was only one choice. That pop-up is really annoying and it would be very nice to be able to distribute this without that.

Its better to change language from the menu later on.

Is there a solution for this or do I have to find my own once again?

Brgds

Thomas

Share this post


Link to post
Share on other sites
Guest ThomasX

Alright, this is what I have come up with so far.

This is really messy when it comes to distribution.

When you start the software a file called "user.config" is created in the users profile.

If you check in "%appdata%\Canneverbe_Limited\...\4.2.2.984\"

(The ... is what seems to be a random named folder for some strange reason)

In this user.config file you look for:

If set like this (see above), it will default to English. You can put whatever language you want in there (between the and ), just use the name of the folder that represents your language in the CDBurnerXP folder.

But how to have this set before you actually start the software is a bigger trick.

This config file does not exist when the software is installed, its being created during first startup.

So, either we have to repack this to get an installer that works the way we want, or we need some help from the developer here.

If nobody else has better ideas...

Brgds

Thomas

Share this post


Link to post
Share on other sites

For the next version, I'll add a special registry key:


[HKEY_CURRENT_USER\Software\CDBurnerXP]
"DefaultLanguage"="System.String:fr-FR"
[/code]

If this is set, CDBurnerXP will not ask for the default language and choose it automatically.

Share this post


Link to post
Share on other sites
Guest ThomasX

This is great news.

However we are in the business of distributing this very soon.

When will the next update be?

Brgds

Thomas

Share this post


Link to post
Share on other sites
Guest ThomasX

Well, the sooner I can get my hands on a version with this registry functionality the happier I would be.

You know how it is, everything should preferably be done yesterday...

So, is the 15th of October a good date? :D:lol:

Share this post


Link to post
Share on other sites
Guest ThomasX

Hey that works! Great! You're the man!!!! Thanks a bunch, really. This is what I call support! 8)

Just one last question.

I want it with the default language, what do I put in the registry string then?

PS. Can you start working at Adobe as well? Would really like this kind of support there too ;) DS

Share this post


Link to post
Share on other sites
Guest ThomasX

I like luck! and you're right. It works! :)

"DefaultLanguage"="System.String:en" Gives me no errors, but it will bring up the Language window.

Share this post


Link to post
Share on other sites
Guest ThomasX

Just put it in SMS and it works perfect!

Ignore the "but it will bring up the Language window." Don't know here that came from.

Thanks a bunch!

Share this post


Link to post
Share on other sites
Guest Janis

After some time of guessing:

The registry path has to be a bit different

This is accepted.

[HKEY_CURRENT_USER\Software\Canneverbe Limited\CDBurnerXP]

"DefaultLanguage"="System.String:da-DK"

Share this post


Link to post
Share on other sites

I make a silent install with the config file

[Setup]

Lang=Russian

Dir=C:\Program Files\CDBurnerXP

Group=CDBurnerXP

NoIcons=0

SetupType=custom

Components=main,nmsaccess,lang,lang\russia

Tasks=desktopicon,desktopicon\common,fileassoc
And add a registry key
[HKEY_CURRENT_USER\Software\Canneverbe Limited\CDBurnerXP]

"DefaultLanguage"="System.String:ru-RU"

But CDBurnerXP starts on English.

Value ru-RU i saw in UserSettings.ini file, that created after manual settings change, so it must be(?) valid.

Is that registry key still used?

Or only that INI-file is the right way?

Share this post


Link to post
Share on other sites


[HKEY_CURRENT_USER\Software\Canneverbe Limited\CDBurnerXP]

"DefaultLanguage"="System.String:ru-RU"

Should it work now? Because I see no effect from this parameter in 4.4.1.3184 (English interface with any language parameters).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.