Jump to content

HP Pavilion dv7 drive not recognized


Guest RMJ1940

Recommended Posts

  • 2 weeks later...
  • 3 months later...

Too all here I have a HP Pavilion dv7 laptop this is what I have try and what does work with this drive cd/dvd Drive HL-DL-ST DVDRAM GT20L firmware DC03

This is what has happen with the new version 4.2.7.1893

It seen most of it is working except for two area that are in the data fields they are listed below

Data disc function does not see drive or can not be selected

copy disc function copy data function does not see drive or can not be selected

My Drive for this is on my laptop HP Pavilion Laptop DV7-1450us

window Vista 64 Home Premium SP2

Many thanks too Flo here for his Great work on this project hope it can corrected

Baitman

Link to post
Share on other sites
  • 3 months later...
Guest

Got the same problem with the GT20L drive in my HP 6830s (running Windows 7 Pro 64bit). As recommended for other drives installing the Intel Matrix Storage Manager did the trick for me, too. There seems to be an incompatibility with the Microsoft AHCI Driver.

I know this thread is quite old, but it's listed on top if you google "cdburnerxp gt20l" - so this might be useful for other people out there.

cu ulf

Link to post
Share on other sites

cu ulf

Thanks for the suggestion on the Intel stuff,, But I have an AMD processor in the HP Laptop, In fact I did download it at one time and my machine refuse it...

Thanks,,

Maybe Flo can provide more answer too this.... :?

Link to post
Share on other sites
Guest

@baitman: If you have an AMD system the "Intel Matrix Storage Manager" will not work (my HP is an Intel system). But there is a link to "RAID drivers for AMD chipsets" on the cdburnerxp troubleshooting page.

http://cdburnerxp.se/help/appendices/troubleshooting

Anyway, make sure you got a recent backup of your system before installing RAID- or AHCI drivers (no matter if Intel or AMD drivers/systems). A wrong driver may cause problems with your hard drive(s) including data loss!

cu ulf

Link to post
Share on other sites
  • 2 weeks later...
Guest diogenes

I also have an HP Pavilion with the same problem ... but I seem to recall having seen other discussion threads where people had similar complaints, and it seems to me the common denominator here is not HP -- it's a 64-bit version of Windows.

(My PC has an AMD processor; I checked AMD's web site, but the Catalyst/RAID drivers only seem to be available as a 32-bit package.)

My HP came with CyberLink Power2Go burning software. But I would prefer to use CD-Burner XP ... if I could get it to work.

Link to post
Share on other sites

I know what you mean there, My HP came with CyberLink Power2Go burning software. But I would prefer to use CD-Burner XP ... plus this program does work along with imgburn software, but I prefer to use Flo program cdBurnerXP .

I have it install on the other machine and it does work great...

The program is so close to working that I am only missing the copy data function that does not see the drive, I believe it is an the data section that it is not listed...

Flor has a great program here just more help is needed I assume on it... :firefox:

Link to post
Share on other sites
  • 2 months later...

I am having the same problem. ie: Windows 7 with an HL-DT-ST BDDVDRW CT10L ATA Device. Although I can "see" the drive and read commercially written CDs, I cannot burn ANY CD or DVD.

I DO have one question. HP has a site for updates but it requires information before continuing. I have a DV7 Laptop BUT, HP is asking for numbers following the DV. For instance "DV7-####". I do not know where to find the numbers following the "DV7". They are not on the label nor on the bios (that I can see). Does anyone know how to find these?

MANY THANKS for any help with the drive OR the numbers.

=Dave=

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 8 months later...

Well, I think you should provide more information advice than the PC and drive name. Probably the OS is added important. I have a HP Pavillion 1155eg with the HL-DT-ST DVDRAM GSA-T50L congenital in AND Windows 7 RC body 7100 64 bit.Well, I think you should accommodate more advice than the PC and drive name. Probably the OS is more important.

Link to post
Share on other sites

Drive HL-DL-ST DVDRAM GT20L firmware DC03

window Window 7 64 Home Premium SP1

HP Pavilion Laptop DV7-1450us

Data Disc compilation there is no compatiable drive listed (shaded out) under Recorder or in drive information of the top menu.

Audio compilation Top menu bar show no compatiable drive listed under drive information, But on the same page for the burning process the drive is listed there.

Burn ISO Image -- Drive is listed under target area

Copy Disc---copy audio part Top menu drive is not listed but on popup menu it is listed, also in the burn section bottom memu drive is listed.

Copy Data section drive is not listed..

Erase disc drive is listed.

Seem like the drive is not listed in all librarys of the program from what I have read, hope this help out so Flo can fix this bug.

Link to post
Share on other sites
Guest Alex

Same exact problem with my Pavilion DV7 1060el with Optiarc DVD RW AD-7561S ATA Device

Drive HL-DL-ST DVDRAM GT20L firmware DC03

window Window 7 64 Home Premium SP1

HP Pavilion Laptop DV7-1450us

Data Disc compilation there is no compatiable drive listed (shaded out) under Recorder or in drive information of the top menu.

Audio compilation Top menu bar show no compatiable drive listed under drive information, But on the same page for the burning process the drive is listed there.

Burn ISO Image -- Drive is listed under target area

Copy Disc---copy audio part Top menu drive is not listed but on popup menu it is listed, also in the burn section bottom memu drive is listed.

Copy Data section drive is not listed..

Erase disc drive is listed.

Seem like the drive is not listed in all librarys of the program from what I have read, hope this help out so Flo can fix this bug.

Link to post
Share on other sites
  • 1 month later...
Guest RogerD

Hello All:

This is a DESPERARATE plea for help. I "like others above" have an HP Laptop Pavilion 7 that came with an HL-DT-ST BDDVDRW CT10L CD/DVD Lightscribe drive. The HP came with Windows Vista which I ran for about a week. I ordered Windows 7 Pro with it and finally decided to upgrade to Win7 (32bit..Wish now I had ordered the 64 bit but alas I didn't). Right after installing Win 7 my DVD writer decided to stop writing ANY CD/DVD's and ONLY READ pre-written CDs (factory written CD's). If I buy a CD program it reads and runs from it perfectly. I CANNOT WRITE TO or read from any DVD. I can "READ" some CD-R's but no CD-RW that I create on my desktop.

Basically, It seems to have stopped being a DVD/CD WRITER and now is a read-only drive. I tried HP support and ALL they could tell me was to revert to your old OS (Vista..I think not). I tried finding the maker of this drive and I "think" it's LG but not sure. There are NO drivers on LG or HP's site that match.

Unlike some others above, My drive IS recognized but useless as a writer. Has anyone found a solution to this? HP is of no use and MS suggest I contact HP or, same as HP, revert to my old OS and be happy....:-(.

Am I stuck with a fancy read only drive? Any help? PLEASE !!!

=Dave R.=

Link to post
Share on other sites
  • 3 weeks later...
Guest Carla

I have a pavilion dv7 2030e, my disc drive is recognised if i click on my computer, i have set up the autoplay option, but still if i put a disc in nothing happens. I've tried every diagnostic tool at my disposal, if anyone knows of a quick fix please let me know, this has been driving me crazy for a long time. I've even done a complete restore to factory settings but still it won't work.

Link to post
Share on other sites
Guest Carla

I have a pavilion dv7 2030e, my disc drive is recognised if i click on my computer, i have set up the autoplay option, but still if i put a disc in nothing happens. I've tried every diagnostic tool at my disposal, if anyone knows of a quick fix please let me know, this has been driving me crazy for a long time. I've even done a complete restore to factory settings but still it won't work.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.