Jump to content

"TSSTcorp CDDVDW SH-S223F ATA device" not recognized

Recommended Posts


I have installed CDBurnerXP on a new ASUS P5Q-E motherboard with Vista 32Bit but the dvd rw drive is not recognized.

Drive is described as "TSSTcorp CDDVDW SH-S223F ATA Device", (Samsung SH-S227F)

The software gives "No compatible drives". I tried this with the latest version

On the same PC other tools like Nero or Infrarecorder work fine with the drive.

Any workaround or fix for that ?

Any way to force the use of the drive ?

I love CDBurnerXP and I don't want to use another burning software, so can you please help ?

Link to post
Share on other sites

Just bought the Samsung SH-223F (SATA), and have the same problem. Vista Ultimate 32bit, Gigabyte GA-P35-DS3 motherboard.

I can read DVD/CD discs, but can't burn with cdburnerxp (device not recognized). Haven't tried Nero or other programs yet.

EDIT: It actually says "The drive(s) could not be initialized...". Updated the firmware to SB02, but still no go :(

Link to post
Share on other sites
  • 2 weeks later...
Guest richard1967

I have the same problem, but it used to work when plugged it in the first time via SATA in my excisting Vista. I even burned a double layer without problems with it. After i reinstalled my Vista however it did not reconize it anymore. Maybe it has to do with re-arranging the drive letters in the diskmanager? I did that and afterwards installed CDBurnerXP. :firefox:

Link to post
Share on other sites
  • 4 weeks later...
Guest Helper 2.0

Depending on your chipsets, if you have intel please install intel matrix storage driver, for amd go to game.amd.com and download raid driver.

Link to post
Share on other sites
  • 2 months later...

I have the same device for SATA and it was working under Windows XP but in Windows 7 (RC) the cdburnerXP just gives me the note that it is incompatible with my drive even it was working under another OS. Okay, maybe it is because Windows 7 is not finished yet but it seems the same fact like the vista users are expierencing. Has anyone a workaround for this? I take a look into the compatibility list and the device is listed but as SCSI and not SATA.

Link to post
Share on other sites
  • 9 months later...
Guest jobonnichsen

I have problems with my drives

I can not find it and it says in Device Manager

''Windows can not start this hardware device because its configuration information (in registry) is incomplete or damaged. (Code 19)''

What should I do? :(


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.