Jump to content
Sign in to follow this  
Henrik Jensen

FYI: Non-Admin users - Run ones as admin after install

Recommended Posts

Hi there

Well, my first post on this forum and I am so arrogant to come with advices . :roll:

Anyway I just do so I won't forget to tell about this discovery of mine.

My advice is for non-admin users to run CDBurnerXP 3.0.116 as admin, one time after the installation to ensure that certain registry keys get written.

Some background:

I noticed, by using the very important free tool for non-adminers, Regmon from Sysinternals, that CDBurnerXP doesn't write all

reg-entries on install, but rather waits with a few on the first run.

Here are some of the log entries from regmon (edited to fit) running CDBurnerXP for the first time.

cdbxp.exe:2640 CreateKey HKCR\.axp ACCESS DENIED

cdbxp.exe:2640 CreateKey HKCR\.dxp ACCESS DENIED

cdbxp.exe:2640 CreateKey HKLM\Software\Ariad ACCESS DENIED

Note that I ran it the first time on my non-admin account.

As you see cdbxp.exe tries to register some extension HKCR and some entries in the HKLM for the "Ariad Interface Components".

I have no idea if these entries really are important.

Maybe some developers or superusers can clarify.

Bye

Henrik

BTW. Who has made this lovely emoticon :firefox:

Share this post


Link to post
Share on other sites

BTW. Who has made this lovely emoticon

I don't know, I only found it on another forum ;)

About the registry keys I can tell you that the first two are not important. If you don't have any problems with CDBXPP I guess that the third one isn't important either.

Share this post


Link to post
Share on other sites

I don't know, I only found it on another forum ;)

They would be thrilled about it over at mozillazine maan :lol:

About the registry keys I can tell you that the first two are not important. If you don't have any problems with CDBXPP I guess that the third one isn't important either.

Well, I haven't had any trouble yet, and after I saw the ACCESS DENIED writings I ran it ones as administrator, and the regkeys was written then.

Henrik

PS. This emoticon, :firefox:, is going directly into my signiture

[edit] As soon as I have figured out how ? hmm

Share this post


Link to post
Share on other sites

They would be thrilled about it over at mozillazine maan :lol:

Feel free to introduce it there ;)

Well, I haven't had any trouble yet, and after I saw the ACCESS DENIED writings I ran it ones as administrator, and the regkeys was written then.

Well, I guess it won't happen in our next version anyway because of a new setup program and a new interface etc.

Henrik

PS. This emoticon, :firefox:, is going directly into my signiture

[edit] As soon as I have figured out how ? hmm

profile.php?mode=editprofile

Share this post


Link to post
Share on other sites

Well it's stramge, - I've try both BBCode "\:firefox\:", "\[img src=http://cdburnerxp.se/forum/images/smiles/ff.gif\]'>http://cdburnerxp.se/forum/images/smiles/ff.gif\]" and "< img src=http://cdburnerxp.se/forum/images/smiles/ff.gif>"("img" w/o space between "<" & "img" OC), but I don't seem to get it to work.

Flo, how are your signature images tagged ?

BTW, Do you know how to escape BBcode/HTML special chars like "[" & "<" ?

Edit: It suddenly worked with the 1st and 3rd option! It didn't yesterday,- weird ?!!!

Edit2: Come to think of it, It won't go into my signature. I think people will find an animated signature too impeding when reading post, I do anyway. And that would just be counter productive for the cause, right ? ;)

Share this post


Link to post
Share on other sites

Flo, how are your signature images tagged ?

This is my code:


[url=http://www.spreadfirefox.com/?q=affiliates&id=11420&t=82][img]http://sfx-images.mozilla.org/affiliates/Buttons/80x15/white_1.gif[/img][/url] [url=http://www.mozilla.org/products/thunderbird][img]http://www.mozilla.org/products/thunderbird/buttons/thunderbird_blog2.png[/img][/url] - [url=http://cdburnerxp.se/cssparse/css_optimiser.php]CSS Optimiser and Formatter[/url]
[/code]

BTW, Do you know how to escape BBcode/HTML special chars like "[" & "

Either disable those features for your post, or put it in [ code ] :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.