Jump to content

SATA AHCI: Between a Rock and a Hard Place


Recommended Posts

Windows 7 RC 6.1.7100 64-bit

Intel Desktop Board DP965LT (ICH8 Southbridge) in AHCI Mode

Plextor PX755SA (PX775A, SATA version), detected as "PLEXTOR DVDR PX-755A ATA Device".

Motherboard BIOS has been flashed to the latest version.

Optical drive firmware has been flashed to the latest version.

Windows explorer burns files fine.

CDBurnerXP 4.2.4.1420 does not detect any compatible burners (of course).

Running it in XP Compatibility Mode (XP SP3) or Vista Compatibility Mode (Vista SP2) with "Run as Administrator" turned on doesn't help.

Granting full permissions for every group and user under Security settings doesn't help. (Just thought I'd try.)

The DataWriter.exe demo from NuMediaSoft (demo.zip) crashes with a JIT COM error on launch, shows no drives in the demo UI, then crashes again when I exit. Yes, it was copied to the CDBurnerXP program folder. It did not make any difference if I overwrote the Interop.NMSDVDXLib.dll file. Both the one in demo.zip and the one already installed by CDBurnerXP are version 1.0.0.0. (Also, they haven't updated their website in two years. This is discouraging for hoping that NuMediaSoft will ever fix it if it's a problem with their Burning SDK for .NET 2.0 which I'm sure the CDBurnerXP folks paid a bundle for.)

Also, this is a new, clean install. No antivirus or possibly conflicting third party software. Nothing except drivers, CDBurnerXP, JRE 1.6r14 and some Flash development tools for work.

Here's the rub:

I need to keep AHCI on to get full performance from my hard drive.

Forcing regression to older Vista x64 drivers for the ICH8 chipset just to make CDBurnerXP happy seems like a Bad Idea, not to mention messy and sloppy as hell.

The only Windows 7 64-bit drivers available from Intel are beta Chipset Drivers, which do their job beautifully (everything works as it should), but it doesn't resolve this issue.

This motherboard does not have an ICH8R southbridge; RAID is not an option. The Intel Matrix Storage Manager utility will only cause problems, if it will even install. It's not even offered as a download for this motherboard under any OS. UPDATE: I attempted to install the IntelĀ® Matrix Storage Manager 8.7.0.1007 (1/9/2009) from Intel's website; it won't even install due to the system "not meeting the minimum requirements". Compatibility mode also did not help here.

So there you have it. I'm encountering the same "drives in AHCI mode do not exist" with CDBurnerXP and it's at the point now that there's nothing I can do about it. This makes me very sad. I love the program and install it on everything, as well as recommend it to my customers.

I don't think we can blame it on the drivers this time, guys. It's just a scenario the software wasn't built to handle, which is a real shame. I hope the devs get a handle on it soon.

Link to post
Share on other sites
Guest Uli

Same Software (Win 7 RC 64 bit AHCI) but other hardware (AMD X2 on 780G) and SATA LG BD DVD. ImgBurn find the drive and works fine. CDBurnerXP doesn't find it but works fine with en external USB-DVD-Writer.

Link to post
Share on other sites

I was thought I was starting to go nuts, but after reading this post realized I am in the same boat.

Hopefully having the specs might help in a resolution. I am running in AHCI, too.

I don't want to go back to NERO.

Microsoft Windows 7 Ultimate

Version 6.1.7100 Build 7100

System Manufacturer INTEL

System Model DG965WH

System Type x64-based PC

Processor IntelĀ® Core2 CPU 6600 @ 2.40GHz, 2394 Mhz, 2 Core(s), 2 Logical Processor(s)

BIOS Version/Date Intel Corp. MQ96510J.86A.1754.2008.1117.0002, 11/17/2008

Drive D:

Description CD-ROM Drive

Media Loaded No

Media Type DVD Writer

Name TSSTcorp CD/DVDW SH-S183L ATA Device

Manufacturer (Standard CD-ROM drives)

Status OK

Transfer Rate -1.00 kbytes/sec

SCSI Target ID 0

PNP Device ID IDE\CDROMTSSTCORP_CD/DVDW_SH-S183L_______________SB01____\5&2CCB468&0&1.0.0

Driver c:\windows\system32\drivers\cdrom.sys (6.1.7100.13, 144.00 KB (147,456 bytes), 5/13/2009 7:42 PM)

Using cdbxp_4.2.4.1453

Link to post
Share on other sites
Guest

I have the same problem.

I'm running Windows 7 with AHCI enabled.

ImgBurn find the drive, but CDBurnerXP doesn't find it.

LG HL-DT-ST DVDRAM GH22LS40

Link to post
Share on other sites
  • 2 weeks later...
Guest Guest

This has been an ongoing issue for a looooooooooong time now - more than a year? Don't hold your breath on getting it fixed in the program itself.

Link to post
Share on other sites
Guest Kalanga

I have the same problem. CDBurnerXP don't burn DVDs and CDs in Windows 7. It worked with the same machine but with Windows Vista.

Link to post
Share on other sites
  • 2 weeks later...

I also have the same problem. It can't find my SATA DVD/CD burner unless I install the RAID drivers. I am using a Gigabyte motherboard with an AMD processor. It found my drive without additional drivers running XP, Vista, and Windows 7 RC. It broke when I tried it with Windows 7 RTM. Windows 7 RTM can find the drive as I was able to burn a windows repair disk.

Link to post
Share on other sites

Blue Screen WinXP 64bit, AHCI Mode

Hello,

I get always a blue screen, by the way this is very rarely on my system ;-)

Mainboard ASUSTek P5N-VM WS

BIOS AHCI

DVD HL-DT-ST DVDRAM GH22NS40

Everything works fine, when I use BIOS IDE Mode (installed XP several times to check many things...)

but when I use AHCI mode I get problems with CDBurnerXP.

Even in AHCI mode the drive is detected corectly. I can erase disks with CDBurnerXP. But when I want to write it, I get a blue screen:

Driver_irgl_not_less_or_equal

...

STOP: 0x000000D1 (Ox0000000038, 0x00000002, 00000000000, XFFFFFADF29241BD6)

SCSIPORT.SYS - Address FFFFFADF29241BD6 base at FFFFFADF29239000,

Luckily I can write CDs without using CDburnerXP even in AHCI. Copying with XP-Explorer (drag and drop) into the DVD-Burner and burning works fine...

Oliver

Link to post
Share on other sites

Since other burning applications/utilities work, I vote for changing the way CDBurnerXP accesses the drive. Having to install additional (usually unreliable) AHCI drivers is the last standing issue I'm having with CDBurnerXP.

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.