Jump to content

Only Track at Once available (no SAO/DAO)

Recommended Posts

For a long time, CDBurnerXP used to include radio buttons to select between DAO and TAO in the burn dialog.

After upgrading a week or so ago, I get instead a drop-down box with a single item - Track at Once!

I unfortunately fell for it and burned a couple of DVDs in TAO mode, thinking it's no big deal, and now of course I can't read them on of the DVD drives I use.

Why could this happen? Is there a way to bring back sanity and get rid of this craptastic TAO-only "feature"? I pretty much cannot use CDBurnerXP any more.

I've tried out imgburn, but that particular piece of basket-case software mixes common, everyday options (like DAO /TAO) with dangerous ("advanced") options. Not very confidence-inspiring.

Link to post
Share on other sites

Basically, in this version only those modes are shown, which are actually supported by your drive. So there shouldn't be any need to display further methods. Did you finalise the disc? And you are probably talking about burning ISO files?

Link to post
Share on other sites

Except the drive actually supports DAO (as all modern internal laptop DVDs do). I can burn DAO in Linux (cdrecord), under BurnAware Free, under ImgBurn, and I could do so even under older versions of CDBurnerXP. Yet the new CDBurnerXP "cleverly" determines that the drive only burns TAO.

I was trying to burn an ISO image onto a blank DVD-R -- no fancy scenarios.

Finalizing the disk unfortunately makes things even worse (I was getting read errors before, now I can't mount the DVD at all).

If mode detection is faulty / immature, perhaps adding a check box to "ignore auto-detected modes" would have been a logical choice? When new logic that can potentially render the software useless is included in a release, an option to override that logic should be made available. I would have thought this would be common sense for programmers developing a mature application.

Sorry for the rant, I couldn't resist. Too many wasted hours (and disks).

Link to post
Share on other sites

Well, since older versions (as well as other programs) used to work, there has to be some problem somewhere.

I found out that if I start CDBurnerXP with no disk in the drive, it will let me choose DAO. Then I can insert the blank and start burning. But, alas, the process fails immediately with an error dialog. I cannot read the "Burn progress" tab because as soon as I OK the error dialog, the program exits completely (again, a poor UI decision I reckon) .

Has the actual burning code changed at some point (i.e. are different commands sent to the drive)? I find this bug puzzling. I would have thought that tricking the "supported burn mode detection" logic would suffice.

Link to post
Share on other sites

The error is to be expected, because if the write mode was supported, it'd be shown in the list in the first place. It shouldn't exit the application though, and in fact, I cannot reproduce this behaviour.

The burning code has changed at some point, in the way that a completely different burning library is used. Thus, it is to be expected that there are minor and major differences. I believe that TAO is actually the correct option to choose, the question is what data has been written to the disc if it cannot be read. If it is a problem with the burning library, you could check http://www.rocketdivision.com/starburn.html. If their applications have the same issue, you can post a support request in their forum. Otherwise, you could create a test ISO image, burn it and compare the results by creating an image from the burned disc which you could send to me. Without some kind of "proof" of your problem, support requests to RocketDivision will most likely not lead to any results.

Link to post
Share on other sites

Flo, the TAO disc *can* be read, but only on some drives, while the DAO discs that CDBurnerXP used to produce had maximum compatibility (they were readable even with older drives). This is the crux of the problem. I used to think TAO/DAO doesn't matter, until I tried to mount one of the TAO DVD's on an older machine.

I have temporarily swtiched to creating ISO images in CDBurnerXP and burning them with ImgBurn, which supports DAO properly (but has an extremely poor UI, especially as concerns the Options dialog -- advanced settings are mixed with every-day options). There are other pieces of software as well. But it was nice to use CDBurnerXP for everything.

Link to post
Share on other sites
  • 2 months later...

I have the same danutz3x's problem! It's very frustating for me.

My dvd-recorder is a Pioneer DVR-116D (eide).

I have downgraded at Cdburnerxp, the latest version that works fine.

I hope the problem could be solved with next version.


Link to post
Share on other sites
  • 10 months later...
Guest WallyCZ

Hmm, same problem. Of course, that my recorder supports SAO, but CDBurnerXP means, that is not supported :(

Link to post
Share on other sites
  • 5 years later...

No comprendo... CDBurnerXP: Burn Options says that

Burn Method

Disc-at-once (DAO) / Session-at-once (SAO)

Use SAO when you want to add files later, this option should not be used with Finalize Disc. Newer versions of CDBurnerXP will only use Track-at-once internally (TAO) and no longer offer a choice between the methods for data discs.

& why are the no options to choose DAO / TAO << honestly, I don't get it. I understand what's written in this thread, but disc-at-once is disc-at-once?! o.0

*not to mention that it's the only way to burn discs, DAO.


Edit: Thanks, nvm., downloading teh newest Nero. :$

P.S. 0k, alright... So, everything's cool - my mistake!! ;):)



Edited by Nostromov
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.