Jump to content
Sign in to follow this  
felipegeek

cdbxpcmd - Burn file contents of a folder

Recommended Posts

Hello,

I am attempting to burn the contents of a folder to disc using the command line tool in a script. For example ""C:\test" (with a bunch of jpg files inside). My command is structured as follows:

cdbxpcmd.exe --burn-data -file[\]:C:\test -verify -close -eject.

The folder contains various picture files but the tool reports the following: "Starting to write disc...0 Files, Size: 0.00 KB", then proceeds to burn a disc with nothing on it.

If I specify a file inside the folder: cdbxpcmd.exe --burn-data -file[\]:C:\test\picture1.jpg -verify -close -eject, it works just fine.

In my scenario the contents of this picture folder will be different at each burn attempt so that C:\test\picture1.jpg...picture8.jpg, could be C:\test\picture9.jpg...picture20.jpg the next time so I cannot use a method where file names are explicitly stated.

What am I doing wrong or am I running into a limitation of the CLI version of the program as it is today?

I appreciate any assistance rendered.

Sincerely,

-felipe

Share this post


Link to post
Share on other sites

Flo,

Thanks for the reply. I tried that but it still does not see the files. This is the command I used and it's output.

---------------------------

C:\Wstation>"C:\Program Files\CDBurnerXP\cdbxpcmd.exe" --burndata -dao -close -eject -verify -name:"TestDisc" -folder[\]:"C:\wstation\cdimages"

Starting to write disc...0 Files, Size: 0.00 KB

0%

99%

100%

100%

Burning data disc completed.

Verifying disc...

Verifying: 100%

Verifying completed.

--------------------------------------

The disc actually burns but without any contents, not even the folder itself appears. The disc does however get labled with the name I provided. Besides the contents of the folder not being burned I would expect the program to abort if no files were found to burn.

I tried using a layout file but a it's fixed layout. I didn't see a way to use it to just read the folder as "C:\wstation\cdimages\*.*".

For reference I had this problem under XP SP3 in a VMware VM with a CDRW drive virtually attached to it, and on an Intel-based PC with a USB CDRW attached. I had no problems burning a disc where I specified a source file with the -file switch.

Any other ideas?

--felipe

Share this post


Link to post
Share on other sites
Guest junge

Dear Flo,

i have the same problem, but only when writing folders to the CD root.

So -folder["examplefolder"] works fine while -folder[\] or -folder[""] does't produce any output.

-file[""] works by the way.

--

David

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.