Jump to content
Sign in to follow this  
mikekaganski

Win7+AHCI again

Recommended Posts

Hello.

I like your program very much, but one problem that still isn't solved drives me crazy.

I run Windows 7 on some of my PCs (both x86 and x64 versions), and if AHCI is enabled on them, it makes impossible using your software. E.g., I write this on the PC with Windows 7 Home Premium x64 and CD Burner XP v.4.3.0.2015. It has ASUS P5K-VM mainboard (with Intel chipset, ICH9), and Optiarc DVD RW AD-7173S SATA drive. If I enable AHCI, your program says it doesn't see compatible drives. But at the same time, if I try to erase a disk, CD Burner XP does perfectly show me my drive(!). Firmware upgrade (both drive and mainboard) doesn't help. Intel SATA drivers aren't compatible with this MB, and ASUS doesn't provide its version either. Windows itself is able to recognize and use the recorder abilities of the drive, and so does Nero (so I suppose it's possible for any software). And if I turn off the AHCI feature, your program becomes able to use the drive (fortunately, this PC doesn't fall into BSOD if I turn AHCI off without reinstalling Windows).

And I see many similar complaints all over the forum!

Please do something to fix this, as it's obviously the fault of CD Burner XP, not of anything else.

Share this post


Link to post
Share on other sites
Guest emper

I have the same problem. Please fix it. Nero is awful - it's cutting long names :D. I like CDBurnerXP and I don't want use anythung else. : )

Share this post


Link to post
Share on other sites

For now, you'll have to install the Intel Matrix Storage manager or the like. In "long term future" we'll switch the burning library though.

Share this post


Link to post
Share on other sites
Guest done

Hi,

doesn't the installation of the RAID drivers for AMD chipsets need to have a raid running?

For me, I just cancelled my raid due to HD problems and run my other HD in AHCI mode with the AHCI drivers.

I think, the hds will not be recognized if I install raid drivers. Or am I wrong?

Wouldn't like to try if I have work to restore my system.

Thanks for an answer.

done

Share this post


Link to post
Share on other sites
Guest HystriX
For now, you'll have to install the Intel Matrix Storage manager or the like. In "long term future" we'll switch the burning library though.

Can you explain how to use these utulities to fix problem with using CDBurnerXP? I need just install utility or change some settings?

Share this post


Link to post
Share on other sites
Guest G. Panhans

Guten Tag,

ich benutze das Brennprogramm CDBurnerXP Ver. 4.3.2.2216 64 Bit. Mein BS: Windows 7 64 Bit. Der Brenner ist als Lw "A" definiert.

Folgender Fehler ist mir aufgefallen:

Für alle Brennoptionen wird das DVD/CD-Lw Modell: DVDRRW GSA-4166B erkannt. unabhängig welcher Lw-Buchstabe zugeordnet ist. Benutzt man die Funktion "ISO Image brennen" darf der Lw-Buchstabe nicht "A" sein, denn dann wird kein Lw erkannt. Jeder andere Lw-Buchstabe ("B" - "Z") funktioniert.

Wäre schön wenn Sie den Fehler beheben könnten.

Mit freundlichen Gruß

G. Panhans

Share this post


Link to post
Share on other sites
Guest G. Panhans

Good day

I am using CDBurnerXP ver burn 4.3.2.2216 64 Bit. My OS: Windows 7 64 bit. The burner is defined as "A" LW.

Following error struck me: for all burning options the DVD/CD LW is model: DVDRRW recognized GSA 4166B. regardless which LW letter is attached. To use the function "Burn ISO image" the LW letter "A" may be because no LW is detected. Each other LW letter ("B" - "Z") works.

Would be nice if you could fix.

With kind greeting

G. Panhans

Guten Tag,

ich benutze das Brennprogramm CDBurnerXP Ver. 4.3.2.2216 64 Bit. Mein BS: Windows 7 64 Bit. Der Brenner ist als Lw "A" definiert.

Folgender Fehler ist mir aufgefallen:

Für alle Brennoptionen wird das DVD/CD-Lw Modell: DVDRRW GSA-4166B erkannt. unabhängig welcher Lw-Buchstabe zugeordnet ist. Benutzt man die Funktion "ISO Image brennen" darf der Lw-Buchstabe nicht "A" sein, denn dann wird kein Lw erkannt. Jeder andere Lw-Buchstabe ("B" - "Z") funktioniert.

Wäre schön wenn Sie den Fehler beheben könnten.

Mit freundlichen Gruß

G. Panhans

Share this post


Link to post
Share on other sites
(fortunately, this PC doesn't fall into BSOD if I turn AHCI off without reinstalling Windows).

You only get a BSOD the other way, i.e. install as IDE then switch to AHCI.

DrT

Share this post


Link to post
Share on other sites
Guest TriggerZ

Hi all,

Windows 7 64-bit running on Solid State Drive no burning drive detected in AHCI mode, if switched to IDE in BIOS my burning drive is detected in CDBurnerXP.

Cause SSD to work with all functions AHCI must be turned on - so its no solution to switch AHCI off. Also Intel-Matrix is no solution cause this would give conflicts for TRIM and SSD.

How long we have to wait until CDBurnerXP will work in AHCI-Mode?

Takes me hard to change to another Burning Software cause I really like CDBurnerXP.

thx

TriggerZ

Share this post


Link to post
Share on other sites
Hi all,

Windows 7 64-bit running on Solid State Drive no burning drive detected in AHCI mode, if switched to IDE in BIOS my burning drive is detected in CDBurnerXP.

Cause SSD to work with all functions AHCI must be turned on - so its no solution to switch AHCI off. Also Intel-Matrix is no solution cause this would give conflicts for TRIM and SSD.

How long we have to wait until CDBurnerXP will work in AHCI-Mode?

Takes me hard to change to another Burning Software cause I really like CDBurnerXP.

thx

TriggerZ

The trouble could be with you CD drive rather than CDBurnerXP.

DrT

Share this post


Link to post
Share on other sites
Guest

Hi,

on my Asus notebook Windows 7 Home Premium was installed with AHCI turned on. The CD recorder was recognized by Windows and was working properly.

But CDBurnerXP didn't recognize the recorder.

Turning off AHCI in the bios (on my notebook setting to "Native IDE") causes a re-install of some devices and a restart of Windows. No problems occured and CDBurnerXP recognizes the recorder now. This way to fix the problem is described in the FAQ, too.

Therefore I am sure that CDBurnerXP has problems with enabled AHCI on some Windows 7 systems.

Regards, Markus

Share this post


Link to post
Share on other sites
Guest TriggerZ

Using ImgBurn now - can do it all.

bdw. InfraRecorder and BurnAware Free also are working fine with configuration I wrote above.

@DrT

The Problem is in CDBurnerXP and nothing others - search Internet for cdburnerxp AHCI and you will see.

Share this post


Link to post
Share on other sites

Even if this is waaay off topic, I reply here so a "solution" can be found...

Lieber G. Panhans, diese Frage gehört in einen eigenen Thread und hat hier nichts zu suchen. Trotzdem antworte ich hier, damit es wenigstens eine Antwort gibt.

Diese Limitierung ist wahrscheinlich eine Limitierung von Windows und nicht direkt vom CDBurner. Denn der Buchstabe A ist seit ewigen Tagen für die heute aussterbenden Diskettenlaufwerke reserviert.

Natürlich könnde CDBurner das umgehen, indem die gleiche Brennfunktion implementiert würde wie für erstellte Disks, es kann jedoch sein, dass ISO-Brennen einen anderen Zugriff erfordert.

Dear G. Panhans,this question would have it's correct place in a new thread instead of here. I answer here so that there's an answer availeble.

This limitation is most likely a limitation of Windows and not of CDBurner as the drive letter A is reserved for diskette drives since the very old days.

CDBurner could do a workaround by implementing the same burning function as for authored disks, but maybe it needs another kind of access to the drive for burning ISOs.

Greetings,

DigiTalk

Good day

I am using CDBurnerXP ver burn 4.3.2.2216 64 Bit. My OS: Windows 7 64 bit. The burner is defined as "A" LW.

Following error struck me: for all burning options the DVD/CD LW is model: DVDRRW recognized GSA 4166B. regardless which LW letter is attached. To use the function "Burn ISO image" the LW letter "A" may be because no LW is detected. Each other LW letter ("B" - "Z") works.

Would be nice if you could fix.

With kind greeting

G. Panhans

Guten Tag,

ich benutze das Brennprogramm CDBurnerXP Ver. 4.3.2.2216 64 Bit. Mein BS: Windows 7 64 Bit. Der Brenner ist als Lw "A" definiert.

Folgender Fehler ist mir aufgefallen:

Für alle Brennoptionen wird das DVD/CD-Lw Modell: DVDRRW GSA-4166B erkannt. unabhängig welcher Lw-Buchstabe zugeordnet ist. Benutzt man die Funktion "ISO Image brennen" darf der Lw-Buchstabe nicht "A" sein, denn dann wird kein Lw erkannt. Jeder andere Lw-Buchstabe ("B" - "Z") funktioniert.

Wäre schön wenn Sie den Fehler beheben könnten.

Mit freundlichen Gruß

G. Panhans

Share this post


Link to post
Share on other sites

well its kinda useless for me, i cant use CDBurnerXP as i use AHCI on a AMD Chipset

but there is a fast and clean workaround to get it to work, but it only work on motherboards that has two sata controllers, so you can have all your harddrives/ssds on the AMD/NVIDIA/Intel SATA Controller in AHCI and have your CD/DVD/BD Writer on the other sata controller from jMicron or Silicon Image SATA Controller in IDE Mode

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.