Jump to content

Automatic Insert Notification


Guest Ichinisan

Recommended Posts

Guest Ichinisan

Something that I installed (CDBXP?) has disabled AIN. Though I don't want my discs to autorun/autoplay, I *do* want AIN enabled so that Windows will display the proper disc label. If I boot the computer with an inserted disc that has Autorun.inf information, that information will persist even when I change discs, causing strange behavior.

I isolated the registry key a long time ago when I had this problem due to Microsoft Virtual PC disabling AIN. Now I can't find my old .REG file. I'm sure some of you can find the key in Windows XP.

A little help, please?

Link to post
Share on other sites
Guest

Yeah. Autorun/Autoplay is different from Auto Insert Notification. Windows literally has no idea when I remove/change discs until I try to browse the drive. Even then, it does not refresh the disc icon or media label. If I have a disc in before booting Windows, it will display the icon and label. If I eject it, the icon, label, and Autorun.inf information persists. So the default action of double-clicking the drive will usually result in a "file not found" when it tries to run the EXE specified by the Autorun.inf of the removed disc.

Link to post
Share on other sites

Ah, yes. I had this problem too once. I suggest you download some system tweak-tools to change this setting. I also don't know at the moment which reg-key etc. you have to change...or try google ;)

Link to post
Share on other sites

Did you set "Devices: Restrict CD-ROM access to locally logged-on user only." in "Local Security Policy" ?

That turns off AIN/MCN/Autoplay/whatever you call it.

Otherwise, run gpedit.msc and look at the "Disable Autoplay" item under "Computer Configuration" / "administrative templates" / "System" this turns off automatic start of programs and CD players, but not automatic detection of new CDs ( updating explorer views etc. ) This is what you want.

Next : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom / Autorun if this is 0 turn it back to 1 , becuuse otherwise Windows does not detect new CDs, as you described.

Link to post
Share on other sites

Did you set "Devices: Restrict CD-ROM access to locally logged-on user only." in "Local Security Policy" ?

That turns off AIN/MCN/Autoplay/whatever you call it.

Actually, that sounds like it would only hide the drive from users who are logged-in remotely using Remote Desktop Connection (terminal services).

Next : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom / Autorun if this is 0 turn it back to 1 , becuuse otherwise Windows does not detect new CDs, as you described.

I'll check, but I've been told that Autorun is very different from Auto Insert Notification.

Link to post
Share on other sites

Actually, that sounds like it would only hide the drive from users who are logged-in remotely using Remote Desktop Connection (terminal services).

With microsoft, things sometimes sound different than what they really are :wink:

I'll check, but I've been told that Autorun is very different from Auto Insert Notification.

What did I just say about things looking/soundig different than what they are ( with MS ) ? :wink: :wink:

That Autorun value in registry actually controls AIN ( or MCN - Media Change Notification ). Isn't windows fun ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.