Jump to content

[C] Files with extended characters in the name are dropped when saving a .m3u playlist


Recommended Posts

To reproduce this bug:

  • Create two identical audio files (in my case these are WAV files). Change the name of one so that it contains extended characters. In my case this is a French filename with two e-acute (é) characters.
  • Add both files to a new compilation in CDBurnerXP, and save the compilation as a (.m3u) playlist.
  • Import the saved playlist back into a new compilation in CDBurnerXP. The file with the extended characters will be missing.

The problem is with the saving rather than importing, as if the playlist is created and saved by another application, CDBurnerXP loads it correctly.

 

Link to post
Share on other sites

You should save it as M3U8 file to preserve extended characters. I don't think this is a bug.

 

Thank you for the reply, floele.

However, I'm not sure that you understand me - the problem is not that the extended characters are missing / changed, but that the entire track is dropped completely from the playlist. That can't be by design, surely?

If it is, then in my personal opinion the software should warn you that the playlist can't be completely saved.

Link to post
Share on other sites

It's not dropped when saving, but it can't be read anymore because the playlist contains unsupported characters. I noticed that CDBurnerXP is still missing the option of saving as M3U8 explicitly, will add that to the next release. Also, it looks like CDBurnerXP may use different encodings for reading and writing M3U files which also is not quite correct and needs to be fixed (probably also solves your problem).

Link to post
Share on other sites

Thanks floele. I have a bit more information that may help...

Here is a test playlist written by another program, with two identical files with different names, one with extended characters, one without.

#EXTM3U
#EXTINF:0,Koban - Détacher et Déguiser
D:\music\Koban\(misc)\wav\Détacher et Déguiser.wav
#EXTINF:0,Koban - Détacher et Déguiser
D:\music\Koban\(misc)\wav\Detacher et Deguiser.wav

CDBurnerXP loads both files correctly.

If I then re-save the playlist from CDBurnerXP, here is the result:

#EXTM3U

#EXTINF:215,Koban - Détacher et Déguiser

D:\music\Koban\(misc)\wav\Détacher et Déguiser.wav

#EXTINF:215,Koban - Détacher et Déguiser

D:\music\Koban\(misc)\wav\Detacher et Deguiser.wav

 

As you can see, the only change is the length value in the #EXTINF tags - but if I import the new playlist created by CDBurnerXP back into CDBurnerXP, only the file without accented characters is loaded.

 

One other minor point; when importing playlists, it would be nice if CDBurnerXP remembered the last playlist folder (or if you could set somewhere a default for the folder). I have 100+ playlists to burn to CD, and each time I have to navigate to the folder where my playlists are stored. Not a big problem, just a minor inconvenience.

 

Thanks for your responses; as a professional developer myself I know it can be annoying when people find problems in your software! I do appreciate the work you guys put into this stuff, and I look forward to the next version.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.