Jump to content
Sign in to follow this  
bolero

Burning on Server 2008 (R2) and above

Recommended Posts

I cannot burn with CDBurnerXP on Windows Server 2008 R2.

 

The symptom:

- run CDBurnerXP "normally" and it shows "no compatible drives" on the "disc - data compilation" screen.

- run CDBurnerXP elevated ("as Administrator") and you get your drive access, but now you cannot drag and drop files to the drop area (it shows the forbidden sign)

- with an elevated CDBurnerXP you can use the Add button, but this way you can only add files (e.g. no folders including files)

 

There seems to be a problem with the hosted listview control, that perhaps runs elevated now while Windows Explorer doesn't. As a workaround I tried to run Windows Explorer elevated as well, but unfortunately the solutions isn't that easy ...

 

Does anyone has a solution to that? To me it looks like the core burning ability should be launched with elevated rights, so that CDBurnerXP has burn access to the drive, but the rest of the application should not run elevated. I also tried to run the setup explicitely elevated, but this didn't change a thing.

 

There's some info in this forum or on the net about this, but more on the general problem with access to burning rights on Windows Server systems, but not specifically to this problem. Most people seem to be content to burn an iso image to a CD - which is solvable by ways described in the following articles. But not the problem to either have no burn rights or no permission to drop files for a CD/DVD compilation.

 

For instance in this forum: https://forum.cdburnerxp.se/topic/5980-windows-2008-compatibility/?hl=server+2008#entry23612 or https://forum.cdburnerxp.se/topic/9771-installing-the-application-on-a-server-then-running-from-shortcut-on-domain-client/?hl=server+2008), but they are not helpful in this respect.

There are also some explanations about the basic problem, which boils down to the fact that only the (literal) "Administrator" account (but not any local "admin" account) has access to burning permissions: for instance http://blogs.technet.com/b/askcore/archive/2010/02/19/windows-server-2008-r2-no-recording-tab-for-cd-dvd-burner.aspx

The advice given is to run a third-party burning utility with elevated rights. Well, I'm doing that ... This works for iso burning, for instance with ImgBurn. However, it does not work for burning normal CDs (e.g. drop a collection of files on a CD) with CDBurnerXP.

There are also some older articles which I think apply only to very old versions of CDBurnerXP that advise to install Nero Burning Rights. This is obviously an outdated utility.

This FAQ (https://cdburnerxp.se/help/appendices/troubleshooting) mentions a policy setting, but also says that it shouldn't be necessary for newer versions of CDBurnerXP. Setting it didn't change a thing.

 

Thanks.

Share this post


Link to post
Share on other sites

Drag&drop interaction between elevated and non-elevated processes is not possible, that's not the fault of components used within CDBurnerXP. You need to allow device access for non-elevated users.

 

Upon installation, CDBurnerXP offers you the possibility to allow non-admin device access. If you did that and it still does not work, you might have to change some group policies (see https://cdburnerxp.se/help/Appendices/troubleshooting). Maybe using SPTD (see https://cdburnerxp.se/help/kb/18) also works, but I've never tried it in that context.

Share this post


Link to post
Share on other sites

Hello, sorry for coming back late. I've burned some discs on a different system in the meantime, but want to follow-up and try to get this to work on Server 2008 R2.

You wrote: "Upon installation, CDBurnerXP offers you the possibility to allow non-admin device access".

Unfortunately, no, it doesn't. Maybe it uses a OS list when it should launch this dialog and doesn't identify the OS as Server 2008 correctly. It sure doesn't ask. I just uninstalled the older version of CDB and installed the latest one. It prompted for admin privileges, but it didn't ask about device access.

I already changed group policies some time ago (as explained in the question above I think). It doesn't change a thing.

I didn't try SPTD or, at least, I think so. But I see that I have an SPTD download from earlier this year. I've git to check if I tried it. I'll report back on that.

Anyway, I'm wondering if this prompt for non-admin device access might be the cure? If so, it doesn't come up on Server 2008, either by mistake or by design. If you need some more info on this or if I should do some diagnostics to find out, I'm happy to provide that. Now to check out about SPTD.

Ok, that was fast. Drivers were already installed, so I enabled usage as per the troubleshooting tip. Upon relaunch, the drive showed up as target. However, CDB cannot detect any disc on it. I tried several ones and also CD and DVD, no go, CDB still does not have access to that drive. So, SPTD doesn't help.

Another option, according to this article only the "real" Administrator account can get burn rights on this OS: http://blogs.technet.com/b/askcore/archive/2010/02/19/windows-server-2008-r2-no-recording-tab-for-cd-dvd-burner.aspx Unfortunately, even that does not work. Without SPTD I see the drive but it can't detect the disc (or maybe it's already with SPTD and I just don't know it) and I can't set it to use SPTD, because there is no UserSettings.ini file in the location where it should be. There's only an empty <version no. of CDB> folder, nothing else. So, at least with the Administrator account CDB should work, but it doesn't.

Edited by bolero

Share this post


Link to post
Share on other sites

The "non admin" access option should only be required on Windows XP and lower IIRC, so it won't be shown on more recent OSes. If the device is detected, but without disc, maybe drive is not working properly? You could try connecting another USB device and check if that works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.